PlanMixPlay first test show complete
Tuesday June 19, 2018

Hello you wonderful human,

A few days ago I finally got the point of completing the first of hopefully not too many test shows with the majorly re-written PlanMixPlay application. As expected, there was no shortage of issues found during the short, short (, short) show. You might wonder why the shows aren't announced in advance - well, two reasons really: First and foremost, they're primarily aimed at being horrible train-wrecks, rather than entertaining. You may think to yourself that you could see the fun in that (you horrible person), but really we're talking wrecks that just crash and cease to broadcast. Believe you me, there's nothing funny about dead air. Second, and perhaps more practically important, I rarely know when I'm ready to actually do a test show more than moments before they'll occur. Once I'm ready, I'll rarely want to wait more given my eagerness to push through and see things break as quickly and as terribly as they can.

Nevertheless, you can bask in a little bit of the after glow here with my run-down of the most glaring issues have/will be tackling before I try setting it all up again:

  • Low mic volume - This was perhaps the biggest offender during the entire broadcast, mostly because it could have been completely avoided had I been even more diligent leading up the first show. In short - my bad. I'm honestly not exactly sure what's causing this without further investigation. The hardware read-outs would seem to indicate that it is a software-side problem - i.e. I am to blame.
  • Dysfunctional mic ducking - Normally, the music is supposed to go a bit quiet when the microphones are activated. This feature seemed to behave completely on its own accord and sometimes increase the volume, other times turn it down. If you did tune in you'd notice that I quickly gave up on speaking over any of the songs. This is definitely also a software based issue.
  • Improper audio track length visualization - Luckily this issue can be filed under 'Only visible to the host' (as a few others). Basically, there's something wrong with how the software currently estimates the length of a track for some small set of tracks. Most of them work perfectly fine - Peter W's - 'I love my 64' however, does not.
  • Recorded audio only audible upon mixmap playback - This is perhaps the most difficult to detect bug prior to doing a show. It's a little tricky to explain properly without a longer spiel about how PlanMixPlay is put together, but sufficed to say, trying to fix it uncovered a much larger issue that needed addressing first. This is what's caused the second test show to slip several weeks, rather than just a day or two.
  • Chat bots present during online show - Bots are fine during the testing phase but will be summarily shown the virtual door once the first 'proper' show kicks off.
  • Audible beeps during show - This is most likely due to the G933 headset I use during the shows and while I'm fairly certain I'll figure out a way to solve it, I've not yet looked into how to approach the issue yet. It'll either involve turning the beeps off in the headset software, or working with Xsplit to not record that particular output.
  • Website oddities - The PlanMixPlay website unfortunately also did not exactly behave as intended. Luckily, this can be handled while only streaming directly to YouTube, so it's possible that an upcoming test show will go exclusively to YouTube so as to not pollute SlayRadio with a bunch of dead air. Finally, a few minor bugs also cropped up that I'll get to before the next show.

That's all for now - I imagine it will likely take at least another month or so before I get around to fixing all these issues and doing another test, but I think we should then be fairly close to having a new stable build I can continuously build on and perform with. Excitement!